Brought to you in part by:

Great deals on auto restoration supplies!

.


  Mustangsandmore Forums
  Ford Trucks
  alt light on 1979

Post New Topic  Post A Reply
profile | register | preferences | faq | search

next newest topic | next oldest topic
Author Topic:   alt light on 1979
majik455
Gearhead

Posts: 184
From: duluth ga usa
Registered: Jan 2005

posted 01-26-2006 08:32 AM     Click Here to See the Profile for majik455   Click Here to Email majik455     Edit/Delete Message   Reply w/Quote
Man this crazy light is killing me . it blinks in flashes its on its off....but it charges? new alt new volt reg ????? Any clues ppl
tHANKS Ron

IP: Logged

Whitson
Gearhead

Posts: 110
From: Western Canada
Registered: Dec 2005

posted 01-26-2006 10:53 PM     Click Here to See the Profile for Whitson   Click Here to Email Whitson     Edit/Delete Message   Reply w/Quote
Normally that happens when the alt. brushes wear down to the point they are just barely making contact.
You might want to check for loose wires/connectors first, but you'll need to either replace the brushes or get a rebuilt alternator.

IP: Logged

majik455
Gearhead

Posts: 184
From: duluth ga usa
Registered: Jan 2005

posted 01-27-2006 04:40 PM     Click Here to See the Profile for majik455   Click Here to Email majik455     Edit/Delete Message   Reply w/Quote
it has a new alt so ill star checking wiring.....any other possiblites?

IP: Logged

MLariviere
Moderator

Posts: 4120
From: Biddeford,Me.USA
Registered: May 99

posted 01-27-2006 08:51 PM     Click Here to See the Profile for MLariviere   Click Here to Email MLariviere     Edit/Delete Message   Reply w/Quote
I would check the voltage regulator and its harness carefully.

IP: Logged

cookie_monster
Journeyman

Posts: 22
From: south, central, us
Registered: Nov 2005

posted 01-27-2006 09:59 PM     Click Here to See the Profile for cookie_monster   Click Here to Email cookie_monster     Edit/Delete Message   Reply w/Quote
One of the best things I did on my old '79 was to replace the Motorcraft alt/reg with a Delco (sorry guys....) Alternator. Much easier to work with.

I hate GM stuff. But, if they make 2 things that are worth anything, the alternators (well..the early ones anyway) and Powerglide transmissions aren't too shabby.

IP: Logged

DidgeyTrucker
Gearhead

Posts: 1631
From: Greenbrier, TN USA
Registered: Oct 99

posted 01-28-2006 09:40 PM     Click Here to See the Profile for DidgeyTrucker   Click Here to Email DidgeyTrucker     Edit/Delete Message   Reply w/Quote
Does it do it at idle? Is the idle speed too low? What is the voltage at the battery with the motor off and with the motor running? Should be 12.5v and 14v.

Tracy

IP: Logged

majik455
Gearhead

Posts: 184
From: duluth ga usa
Registered: Jan 2005

posted 01-29-2006 08:55 AM     Click Here to See the Profile for majik455   Click Here to Email majik455     Edit/Delete Message   Reply w/Quote
motor off ign on its on norm steady. running blinks on off steady or completely off totally random. took it to autozone they tested and said shes charging fine and I havent had the first sign of problem.

IP: Logged

DidgeyTrucker
Gearhead

Posts: 1631
From: Greenbrier, TN USA
Registered: Oct 99

posted 01-29-2006 12:21 PM     Click Here to See the Profile for DidgeyTrucker   Click Here to Email DidgeyTrucker     Edit/Delete Message   Reply w/Quote
It might be just a finicky regulator. Do you have the old one to put back on for a test?

Tracy

IP: Logged

All times are ET (US)

next newest topic | next oldest topic

Administrative Options: Close Topic | Archive/Move | Delete Topic
Post New Topic  Post A Reply
Hop to:

Contact Us | Mustangsandmore Front Page

Copyright 2005, Steve LaRiviere. All Rights Reserved.


Ultimate Bulletin Board 5.47d

Amazon Honor System Click Here to Pay Learn More

[Build a free Mustangsandmore.ws Home Page!]

[Posting Pictures]

[About M&M][Acronyms][Calendar][Chat][Classifieds] [Members' Pics]

[M&M Conventions] [M&M Mug Shots]

[ Mustangsandmore.com Bookstore] [ Smokin' Fords] [Tech Articles]