Brought to you in part by:

Great deals on auto restoration supplies!

.


  Mustangsandmore Forums
  '74 to '78 -- The Mustang II
  transmission

Post New Topic  Post A Reply
profile | register | preferences | faq | search

next newest topic | next oldest topic
Author Topic:   transmission
nevadaslim2005
Journeyman

Posts: 3
From: Marina del Rey, CA. USA
Registered: Jul 2005

posted 07-15-2005 05:20 PM     Click Here to See the Profile for nevadaslim2005   Click Here to Email nevadaslim2005     Edit/Delete Message   Reply w/Quote
I have a 76 cobra 2. 302, C4. When I first bought the car and drove it, the trans. shifted fine. After a tune up for CA. smog,it revs up between second and third gear. Iv'e also replaced the trans. filter, vacuum module, and fluid. It only has one vacuum line to the trans. which is hooked up. I didn't change any vaccum lines during the tune up. Plugs, dist. cap, rotor, coil, rebuilt carb. etc. Any suggestions

Nevadaslim2005

IP: Logged

jeffnoel
Journeyman

Posts: 9
From: Clovis, CA
Registered: Jul 2002

posted 07-20-2005 12:15 PM     Click Here to See the Profile for jeffnoel   Click Here to Email jeffnoel     Edit/Delete Message   Reply w/Quote
Try putting the old vacuum modulator back in to see if you got bad one, also check the rubber vacuum line for cracks it may be leaking.

IP: Logged

All times are ET (US)

next newest topic | next oldest topic

Administrative Options: Close Topic | Archive/Move | Delete Topic
Post New Topic  Post A Reply
Hop to:

Contact Us | Mustangsandmore Front Page

Copyright 2005, Steve LaRiviere. All Rights Reserved.


Ultimate Bulletin Board 5.47d

Amazon Honor System Click Here to Pay Learn More

[Build a free Mustangsandmore.ws Home Page!]

[Posting Pictures]

[About M&M][Acronyms][Calendar][Chat][Classifieds] [Members' Pics]

[M&M Conventions] [M&M Mug Shots]

[ Mustangsandmore.com Bookstore] [ Smokin' Fords] [Tech Articles]