Brought to you in part by:

Great deals on auto restoration supplies!

.


JC Whitney clearance center!

  Mustangsandmore Forums
  '74 to '78 -- The Mustang II
  electrical problem??

Post New Topic  Post A Reply
profile | register | preferences | faq | search

next newest topic | next oldest topic
Author Topic:   electrical problem??
AintNoPinto
Journeyman

Posts: 10
From: IN, USA
Registered: Nov 2002

posted 11-26-2002 12:46 PM     Click Here to See the Profile for AintNoPinto   Click Here to Email AintNoPinto     Edit/Delete Message   Reply w/Quote
I have a 77 cobra II. i have just installed a 347 stroker and an AOD. the car starts fine but then has an awful noise from the bellhousing which picks up speed as the engine does. there are also some spooky electrical things as the "I" side of my starter relay has no wire connected to it. any answers would be greatly appreciated.. i am itching to drive it.

IP: Logged

77sleeper
Gearhead

Posts: 127
From: Mesa Arizona
Registered: Jun 2001

posted 11-26-2002 07:27 PM     Click Here to See the Profile for 77sleeper   Click Here to Email 77sleeper     Edit/Delete Message   Reply w/Quote
the I side is not use on my 77 302 coupe

Did you fill the converter before you installed it?

[This message has been edited by 77sleeper (edited 11-26-2002).]

IP: Logged

AintNoPinto
Journeyman

Posts: 10
From: IN, USA
Registered: Nov 2002

posted 11-26-2002 07:57 PM     Click Here to See the Profile for AintNoPinto   Click Here to Email AintNoPinto     Edit/Delete Message   Reply w/Quote
i was underneath the thing today... looks like the starter is hitting the flywheel...i am going to shim it back in the morning... wish me luck.. the tranny was full before and never drained... but we didnt specifically fill the torque converter. i am sure its the starter making the noise though. thanks for the help..

IP: Logged

AintNoPinto
Journeyman

Posts: 10
From: IN, USA
Registered: Nov 2002

posted 12-03-2002 11:27 AM     Click Here to See the Profile for AintNoPinto   Click Here to Email AintNoPinto     Edit/Delete Message   Reply w/Quote
well i finally shimmed the starter back and lo and behold no more noise. now i have to tighten the exhaust manifold on the drivers side and put exhaust on the passenger. she sounds mean and looks smokey LOL. i tried to sell her about 6 months ago but the high bidder never paid. and then she caught fire from a leaky carb. its been a long way back. i was looking at everyones pictures and i am sure mine is in worse shape than most of your projects... at least cosmetically. if i can get the blower motor in anytime soon she will go back to being a driver. you guys have some gorgeous cars out there and i am hopin to catch up someday.

------------------

IP: Logged

All times are ET (US)

next newest topic | next oldest topic

Administrative Options: Close Topic | Archive/Move | Delete Topic
Post New Topic  Post A Reply
Hop to:

Contact Us | Mustangsandmore Front Page

Copyright 2005, Steve LaRiviere. All Rights Reserved.


Ultimate Bulletin Board 5.47d

Amazon Honor System Click Here to Pay Learn More

[Build a free Mustangsandmore.ws Home Page!]

[Posting Pictures]

[About M&M][Acronyms][Calendar][Chat][Classifieds] [Members' Pics]

[M&M Conventions] [M&M Mug Shots]

[ Mustangsandmore.com Bookstore] [ Smokin' Fords] [Tech Articles]