Brought to you in part by:

.

Shop Eastwood for your Auto Restoration Needs!


  Mustangsandmore Forums
  '64 1/2 to '73 -- The Classic Mustang
  tach isn't working right

Post New Topic  Post A Reply
profile | register | preferences | faq | search

UBBFriend: Email This Page to Someone! next newest topic | next oldest topic
Author Topic:   tach isn't working right
BLstangin
Gearhead

Posts: 388
From: South Central MN
Registered: Apr 2002

posted 06-25-2002 09:51 PM     Click Here to See the Profile for BLstangin   Click Here to Email BLstangin     Edit/Delete Message   Reply w/Quote
Hello, my car didn't have a tach on it when I bought it, but it had and still has an accel super coil. I have been working on it for 2 years and am finally getting close to driving it. My dad put a pertonix ignitor in it and it is wired red wire to positive on coil and black to negative on the coil. I have a sun super tach 2 hooked up to the negative side of the coil, and yes it is hooked up right, but for some reason the needle doesn't always stay steady. Sometimes it will read right on and then all of the sudden it will read way off, an example is, the motor will be running approximatly 2,000 rpm, but my tach will fluctuate and read between 3,500 and 4,000 rpm. I have tried putting in a diode as pertronix told me to and that hasn't made a difference. Also the coil will shock you if you touch the negative post when it is running, is that normal?
Any help would be appreciated.

IP: Logged

Moneymaker
Administrator

Posts: 19751
From: Lyons, IL, USA
Registered: May 99

posted 06-25-2002 10:03 PM     Click Here to See the Profile for Moneymaker   Click Here to Email Moneymaker     Edit/Delete Message   Reply w/Quote
You should not get a shock from the negative side of the coil. It is only primary voltage. Sounds like something is grounding out where it shouldn't be. Try the tach on another car. Any other car or ignition and see if the problem still exists.

------------------
Alex Denysenko
Co-Administrator and Moderator/ non 65-66 Mustang owner sensitivity co-ordinator

NHRA/IHRA/SRA member
NHRA and IHRA SS/LA National Record Holder '00, '01, & '02
Fleet of FoMoCo products including 88 ASC McLaren Mustang #28
Part time secret agent license #0089
Professional Manwhore
The Barry of BarrysGrrl

IP: Logged

BLstangin
Gearhead

Posts: 388
From: South Central MN
Registered: Apr 2002

posted 06-25-2002 11:17 PM     Click Here to See the Profile for BLstangin   Click Here to Email BLstangin     Edit/Delete Message   Reply w/Quote
I didn't think so, I put and HEI in my uncles camaro and I tried his old coil and it seemed to solve the problem. So is there something wrong with my coil, or is it just the way my coil is? ( accel super coil) I hate to buy a new one and have it do the same thing. I want to use the same type of coil because everything is already set up for it. Thanks.

IP: Logged

All times are ET (US)

next newest topic | next oldest topic

Administrative Options: Close Topic | Archive/Move | Delete Topic
Post New Topic  Post A Reply
Hop to:

Contact Us | Mustangsandmore Front Page

Copyright 2003, Steve LaRiviere. All Rights Reserved.


Ultimate Bulletin Board 5.47d

Amazon Honor System Click Here to Pay Learn More

[Build a free Mustangsandmore.ws Home Page!]

[About M&M][Acronyms][Calendar][Chat][Classifieds] [Members' Pics] [M&M Mug Shots]

[ Mustangsandmore.com Bookstore] [Mustangsandmore.com T-Shirts][Tech Articles]